Ch3_BacSc.pdf

Description
CH 3: Les structures de contrôle conditionnelles Professeur : Mohamed TRABELSI Chapitre n°3 : Les structures de contrôle conditionnelles Objectifs du cours : ã Maîtriser la structure Si. ã Maîtriser la structure Selon. Leçon 1 La structure de contrôle conditionnelle simple I - La forme réduite 1. Syntaxe et vocabulaire : (voir livre page 72, 73) 2. Définition : (voir livre page 75) 3

Please download to get full document.

View again

of 8
All materials on our website are shared by users. If you have any questions about copyright issues, please report us to resolve them. We are always happy to assist you.
Information
Category:

Documents

Publish on:

Views: 9 | Pages: 8

Extension: PDF | Download: 1

Share
Tags
Transcript
  CH 3: Les structures de contrôle conditionnelles Professeur : Mohamed TRABELSI Chapitre n°3 : Les structures de contrôle conditionnelles  Objectifs du cours : ã   Maîtriser la structure Si. ã   Maîtriser la structure Selon. Leçon 1 La structure de contrôle conditionnelle simple   I - La forme réduite 1.   Syntaxe et vocabulaire : (voir livre page 72, 73)   2.   Définition : (voir livre page 75) 3.   Remarques ã   L'initialisation est le fait d'affecter une valeur initiale à un objet. ã   En Pascal, si le traitement après Then est composé d’une seule instruction, cette dernière peut être présentée sans les deux délimiteurs Begin et End   Activité 1  : Écrire une analyse qui permet de saisir un caractère et une chaîne puis afficher un message pour dire si le caractère existe dans la chaîne ou non. a.   Analyse  Nom  : recherche S L.D.E O.U 4 3 1 2 5 Résultat   = Ecrire (c, msg, ch) msg = [msg ←   N'existe pas ] Si POS (c, ch) ≠  0 alors msg ←   Existe Fin si c = Donnée ( Donner un caractère ) ch = Donnée ( Donner une chaîne ) Fin  recherche c ch msg http://web-tic.net 1 / 8    CH 3: Les structures de contrôle conditionnelles Professeur : Mohamed TRABELSI T.D.O Objet Type Rôle ch Chaîne c Caractère Caractère recherché msg Chaîne message  b.   Algorithme 0)   Début  recherche 1)   écrire ( Donner un caractère ) Lire (c) 2)   écrire ( Donner une chaîne ) Lire (ch) 3)   msg ←   N'existe pas Si POS (c, ch) <> 0 alors msg ←   Existe Fin si 4)   Ecrire (c, msg, ch) 5)   Fin  recherche c.   Traduction en Pascal (voir fichier : if_pos.pas ) II - La forme alternative  1.   Syntaxe et vocabulaire : (voir livre page 77, 78)   2.   Définition : (voir livre page 80)   Activité 2  : Saisir une chaîne de caractère et vérifier si elle est composée de plusieurs mots. a.   Analyse  Nom  : phrase S L.D.E O.U 2 1 3 Résultat   = Affichage Affichage = [ ] Si POS ( , ch) = 0 alors écrire ( Mot ) Sinon écrire ( Phrase ) Fin si ch = Donnée ( Donner une chaîne : ) Fin  phrase ch http://web-tic.net 2 / 8    CH 3: Les structures de contrôle conditionnelles Professeur : Mohamed TRABELSI T.D.O Objet Type Rôle ch Chaîne  b.   Algorithme 0)   Début  1)   écrire ( Donner une chaîne ) Lire (ch) 2)   Si POS ( , ch) = 0 alors écrire ( Votre chaîne est composée d'un seul mot ) Sinon écrire ( Votre chaîne est composée de plusieurs mots ) Fin si 3)   Fin   c.   Traduction en Pascal (voir fichier : phrase1.pas )  ã   Cas particulier : ch contient message ⌦   Votre chaîne est composée d'un seul mot Faux ! ch contient o message ⌦   Votre chaîne est composée de plusieurs mots Faux !  ch contient message ⌦   Votre chaîne est composée de plusieurs mots Faux !  Version 2 0)   Début  1)   écrire ( Donner une chaîne ), Lire (ch) 2)   Tant que (ch [1] = ) et (long (ch) ≠  0) faire Efface (ch, 1, 1) Fin Tant que 3)   Tant que ch [Long (ch)] = et (long (ch) ≠  0) faire Efface (ch, Long (ch), 1) Fin Tant que 4)   Si Long (ch) = 0 alors écrire ( La chaîne est vide ) Sinon Si POS ( , ch) = 0 alors écrire ( Votre chaîne est composée d'un seul mot ) Sinon écrire ( Votre chaîne est composée de plusieurs mots ) Fin si 5)   Fin   d.   Traduction en Pascal (voir fichier : phrase2.pas )  http://web-tic.net 3 / 8    CH 3: Les structures de contrôle conditionnelles Professeur : Mohamed TRABELSI Leçon 2 La structure de contrôle conditionnelle généralisée   I - Vocabulaire et syntaxe (voir livre page 86, 87)  II - Définition (voir livre page 90)    Activité 1  :    Écrire un programme qui affiche l'heure système, Avancer cet horaire d'une seconde et l'afficher au milieu de la fenêtre d'exécution. Exemple : 15:34:26   15:34:27 a.   Analyse  Nom   : heure_système S L.D.E O.U 4 3 2 1 5 Résultat   = Écrire (h, : , m, : , s) h, m, s = [ ] Si s< 59 alors s ←  s + 1 Sinon Si m<59 alors s ←  0 m ←  m + 1 Sinon Si h<23 alors s ←  0 m ←  0 h ←  h + 1 Sinon s ←  0 m ←  0 h ←  0 Fin si Écrire (h, : , m, : , s) Gettime (h, m, s, c) Fin  heure_système h m s c T.D.O Objet Type Rôle h mot Heure m mot Minute S mot Seconde c mot Centième de seconde http://web-tic.net 4 / 8  
Related Search
We Need Your Support
Thank you for visiting our website and your interest in our free products and services. We are nonprofit website to share and download documents. To the running of this website, we need your help to support us.

Thanks to everyone for your continued support.

No, Thanks